СРОЧНО!!!1)Составьте программу сумму и разность целых чисел A и B.2)Составьте программу...

0 голосов
18 просмотров

СРОЧНО!!!1)Составьте программу сумму и разность целых чисел A и B.2)Составьте программу нахождения первой цифры двухзначного числа а.3) Составьте программу вычисление суммы двузначного числа а.4) Составьте программу вычисления суммы цифр трехзначного числа а. Это разные задания !!!!


Информатика (37 баллов) | 18 просмотров
0

Почему так мало баллов даете за такие задания? Никто их не будет делать за это!

0

Потому ,что больше нет !

Дан 1 ответ
0 голосов
Правильный ответ

1)
Program n1;
var a,b: integer;
begin
write('введите а и b: ');
readln(a,b);
writeln('сумма: ',a+b);
writeln('разность: ',a-b);
end.
2)
Program n2;
var a: integer;
begin
writeln('введите а: ');
readln(a);
writeln('первая цифра(десятки): ',a div 10);
end.
3)
Program n3;
var a: integer;
begin
write('введите число: ');
readln(a);
writeln('сумма цифр= ',(a mod 10)+(a div 10));
end.
4)
Program n4;
var a: integer;
begin
write('введите число: ');
readln(a);
writeln('сумма цифр= ',round((a mod 10)+((a mod 100)-(a mod 10))/10+(a div 100)));
end.

(149k баллов)