Мне нужно отладить программу в Паскале. Я её составила, но она работает не до конца правильно. Исправьте пожалуйста.
Текст задачи:
Напишите программу для решения следующей задачи. Девятиклассники участвовали в викторине по математике. Необходимо было ответить на 20 вопросов. Победителем викторины считается участник, правильно ответивший на наибольшее количество вопросов. На сколько вопросов победитель ответил правильно? Если есть участники викторины, которые не смогли дать правильный ответ ни на один из вопросов, выведите YES, иначе выведите NO. Гарантируется, что есть участники, правильно ответившие хотя бы на один из вопросов. Программа получает на вход число участников викторины N (1 ? N ? 50), затем для каждого участника вводится количество вопросов, на которые получен правильный ответ.
Моя программа:
Program p1;
var
a,b,max,n:integer;
begin
max:=0;
writeln('Введите кол-во участников>>');
readln(n);
writeln('Введите кол-во правильных ответов данных участником 1');
readln(a);
max:=a;
for b:= 1 to n-1 do
writeln('Введите кол-во правильных ответов данных участником ',b+1);
readln(a);
if (a > max) then
max:=a
else
begin
if a=0 then
writeln('YES')
else
writeln('NO');
end;
writeln('Победитель набрал ',max,' кол-во баллов');
end.