Напишите программу ** питоне, пожалуйста. Программа получает ** вход строку и символ....

0 голосов
72 просмотров

Напишите программу на питоне, пожалуйста.
Программа получает на вход строку и символ. Используя метод find(), напишите программу, которая выводит все позиции, где встречается этот символ.


Информатика (29 баллов) | 72 просмотров
Дан 1 ответ
0 голосов

S = input('Строка: ')
c = input('Символ: ')[0]
o = []
p = 0
while True:
    r = s.find(c, p)
    if r == -1:
        break
    else:
        o.append(str(r))
        p = r + 1
print('Позиции:', ', '.join(o))

(7.2k баллов)