Написать программу пересчета величины временного интервала, заданного в минутах, в...

0 голосов
426 просмотров

Написать программу пересчета величины временного интервала, заданного в минутах, в величину, выраженную в часах и минутах. Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом). Введите величину временного интервала ( минутах) и нажмите -> 150
150 минут − это 2 ч. 30 мин.


Информатика (31 баллов) | 426 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//прога на Pascal`е
var
   a : longint;
begin
write ('Введите кол-во минут: ');
read(a);
write (a, ' минут{ы) - это ', (a div 60) : 3, ' ч. ', (a mod 60) : 2, ' мин.');
end.

(3.8k баллов)