Помогите, пожалуйста, написать программу для паскаль abc, которая меняет в массиве...

0 голосов
42 просмотров

Помогите, пожалуйста, написать программу для паскаль abc, которая меняет в массиве наибольшее и наименьшее число.
Например,
Исходные числа: 5 6 1 2 7
Программа меняет на: 5 6 7 2 1


Информатика (1.7k баллов) | 42 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program n1;
const n = 6;
var a : array[1..n] of integer;
i, max, min, temp : integer;
begin
for i := 1 to n do readln(a[i]);
min := 1;
max := 1;
for i := 1 to n do
begin
if a[i] > a[max] then max := i;
if a[i] < a[min] then min := i;
end;
temp := a[max];
a[max] := a[min];
a[min] := temp;
for i := 1 to n do write(a[i],' ');
end.

(149k баллов)
0

Громадное спасибо за помощь!!!!!!!!Очень выручили!!!!!!!!!!!!!!!!