Помогите Написать программу ** языке С#, которая по введенному значению аргумента...

0 голосов
125 просмотров

Помогите Написать программу на языке С#, которая по введенному значению аргумента вычисляет значение функции, заданной в виде графика. Параметр R вводится с клавиатуры.
Заранее огромное спасибо.


image

Информатика (15 баллов) | 125 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Using System;

public class Test
{
public static void Main()
{
double r, x, y;
Console.WriteLine("r = ");
r = double.Parse(Console.ReadLine());
Console.WriteLine("x = ");
x = double.Parse(Console.ReadLine());
if (x<=0) y = -0.5*x;<br> else if (x<=r) y = -Math.Sqrt(4-x*x)+2;<br> else if (x<=2*r) y = Math.Sqrt(4-(x-2)*(x-2));<br> else y = -x+2*r;
Console.WriteLine("y = " + y);
Console.ReadLine();
}
}

Пример:
r = 2
x = 3
y = 1.73205080756888

(194k баллов)