Задано натуральное число N. Напишите программу, которая выведет ** экран все числа от 1...

0 голосов
100 просмотров

Задано натуральное число N. Напишите программу, которая выведет на экран все числа от 1 до N в обратном порядке.

Входные данные
Задано натуральное число N, не превосходящее 1000

Выходные данные
Должны быть выведены в строку N натуральных чисел, разделенные пробелами.
В МОЕЙ ПРОГРАММЕ ПОЧЕМУ ТО ВЫВОДИТСЯ: 2 1 2 КАК ИЗБАВИТЬСЯ ОТ ВТОРОЙ ДВОЙКИ ПОСЛЕ ЕДИНИЦЫ?


Информатика | 100 просмотров
Дан 1 ответ
0 голосов

Program z2;  Var n,i:integer; Begin  Write('N = '); readln(n);  while n>0 do  begin    write(n,'  ');    n:=n-1;  end;End.

(196 баллов)
0

где пишет?

0

Program z2;
Var n,i:integer;
Begin
Write('N = '); readln(n);
for i:=1 to n do
write(i,' ');

writeln;
while n>0 do
begin
write(n,' ');
n:=n-1;
end;
End.

0

Первоначальную строку не вывел