Напишите программу, которая выводит все простые числа в диапазоне от K до N ( 2 ≤ K ≤ N ≤...

0 голосов
671 просмотров

Напишите программу, которая выводит все простые числа в диапазоне от K до N ( 2 ≤ K ≤ N ≤ 100000 ), оканчивающиеся на цифру 3.

Входные данные:Входная строка содержит два натуральных числа, разделённые пробелом, K и N ( 2 ≤ K ≤ N ≤ 100000 ).
Программа должна вывести все простые числа, оканчивающиеся на цифру 3, в диапазоне от K до N в одну строку, разделив их пробелами. Если таких чисел нет, нужно вывести число 0.
Например входные данные :15 22; выход:0. Программа в паскале ABC 1.8


Информатика (46 баллов) | 671 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program n1;
function pr(a:longint ):boolean;
var i: longint;
begin
if a<2 then pr:=false<br>else
begin
pr:=true;
for i:=2 to round(sqrt(a)) do
if a mod i=0 then pr:=false;
end;
end;
var k,n,x: longint;
b: boolean;
begin
b:=false;
readln(k,n);
if (k>=2) and ( n>=k) and (n<=100000) then for x:=k to n do if (x mod 10=3) and (pr(x)=true) then<br> begin
b:=true;
write(x,' ');
end;
if b=false then writeln(0);
end.

(150k баллов)