Юношам 15, 16, 17 лет (Дима, Саша, Сергей). Составить программу выбора. в программе...

0 голосов
58 просмотров

Юношам 15, 16, 17 лет (Дима, Саша, Сергей). Составить программу выбора.
в программе Паскаль.


Информатика (15 баллов) | 58 просмотров
0

Что именно должна делать программа?

0

вариант Case случайности.

0

Спрошу иначе: Что программа должна получать на вход, и что должна выдавать? Приведите пример

0

WriteLn('Какую отметку ты получил по физике?');ReadLn(otmetka);case otmetka of1, 2: WriteLn('кoшмap');3: WriteLn ('неважно');4: WriteLn('xopoшo');5: WriteLn ('отлично');ELSE WriteLn('Taкиx отметок не бывает')

0

То есть, программа должна получить на вход возраст, а выдать имя?

Дан 1 ответ
0 голосов
Правильный ответ

Var n:integer;
begin
write('n = ');
readln(n);
case n of
 15: writeln('Дима');
 16: writeln('Саша');
 17: writeln('Сергей');
 else writeln('Нет таких');
 end;
end.

Пример:
n = 17
Сергей

(194k баллов)