Напишите программу для Паскаля. Возвести чётное число в квадрат, а нечётное в куб.

0 голосов
123 просмотров

Напишите программу для Паскаля.
Возвести чётное число в квадрат, а нечётное в куб.


Информатика (60 баллов) | 123 просмотров
Дан 1 ответ
0 голосов

Var
x,rez:integer;
begin
readln(x);
if x mod 2 = 0 then
rez:=x*x
else
rez:=x*x*x;
writeln (x);
end.

(1.2k баллов)