Напишите программу, которая определяет, верно ли, что введённое число содержит две...

0 голосов
432 просмотров

Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число. Выходные данные Программа должна вывести слово 'YES', если в числе есть две одинаковые цифры, стоящие рядом, и слово 'NO', если такой пары цифр нет. Примеры входные данные 5221 выходные данные YES входные данные 1232 выходные данные NO
ПРОГРАММА ДОЛЖНА БЫТЬ С ЦИКЛОМ БЕЗ КОНСТАНТ


Информатика (1.3k баллов) | 432 просмотров
0

Как раз с циклом мне и надо, ибо тема такая)

Дано ответов: 2
0 голосов
Правильный ответ

Program n1;
var n: integer; b: boolean;
begin
readln(n);
n := abs(n);
b := false;
repeat
b := (n mod 10 = n mod 100 div 10) and (n > 0);
n := n div 10
until b or (n <= 9);<br>if b=false then writeln('no') else writeln('yes');
end.

(150k баллов)
0 голосов

var s: string;
    i,k: integer;
begin
  write('число:  ');  readln(s);
  k:=0;
  for i:=2 to length(s) do
  if s[i-1]=s[i] then
  begin
    writeln('YES');
    k:=1;
    break;
  end;
  if k=0 then writeln('NO');
end.

число:  1235
NO

число:  115524
YES






(9.7k баллов)