Написать программу решения задачи: Вводить целые числа с клавиатуры, пока не будет введен...

0 голосов
126 просмотров

Написать программу решения задачи: Вводить целые числа с клавиатуры, пока не будет введен ноль.
а) Найти сумму введенных чисел.
b) Найти количество четных отрицательных чисел среди введенных.
c) Найти максимальное число среди введенных.


Информатика (112 баллов) | 126 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//PascalABC.Net 3.2
begin
var max:=-1000000000;
var sum:=0; var count:=0; var a:=0;
repeat
a:=readinteger('Введите число: ');
if (a.IsEven) and (a<0) then inc(count);<br>if a>max then max:=a;
sum+=a;
until a=0;
writeln ('a) ', sum);
writeln ('b) ', count);
write  ('c) ', max);
end.

(3.8k баллов)