Написать программу среднее геометрическое всех чисел ** отрезке (a b)

0 голосов
49 просмотров

Написать программу среднее геометрическое всех чисел на отрезке (a b)


Информатика (17 баллов) | 49 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
a,b:integer;
P:real;
Begin
P:=1;
Write('a = ');ReadLn(a);
Write('b = ');ReadLn(b);
For b:= a to b do
    P:=P*b;
Write(Power(P,1/(b-a+1)));
End.

(34.0k баллов)