Напишите программу, которая вычисляет факториал натурального числа N ( 1 ≤ N ≤ 10000 ),...

0 голосов
76 просмотров

Напишите программу, которая вычисляет факториал натурального числа N ( 1 ≤ N ≤ 10000 ), сохранив все значащие цифры. Факториалом называется произведение всех натуральных чисел от 1 до N : N ! = 1·2·3... ( N - 1)· N .

Входные данные
Входная строка содержит натуральное число N ( 1 ≤ N ≤ 10000 ).

Выходные данные
Программа должна вывести факториал числа N .

Примеры
входные данные
6
выходные данные
720
Pascal ABC 1.8


Информатика (46 баллов) | 76 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//PascalABC.NET 3.2, старой версии нет, не могу проверить

begin
  var a: BigInteger := 1;
  for var i := 1 to ReadInteger do
    a *= i;
  write(a)
end.

(13.3k баллов)