Срочноо, помогите!! Напишите программу В ПАСКАЛЕ вычисления выражения: s=x^3+x^5+x^n, где...

0 голосов
227 просмотров

Срочноо, помогите!!
Напишите
программу В ПАСКАЛЕ вычисления выражения: s=x^3+x^5+x^n, где x и n вводятся с клавиатуры. Используйте функцию вычисления
степени.


Информатика (22 баллов) | 227 просмотров
0

Power для возведения в степень использовать можно?

0

нет

0

Написать свою функцию

0

?.

0

стооооп, можно,просто перепуточки вышли

Дан 1 ответ
0 голосов
Правильный ответ

Var
X,N:real;
Begin
Write('x = ');ReadLn(x);
Write('n = ');ReadLn(n);
WriteLn('S = ',x*x*x*(1+x*x)+power(x,n));
End.



С помощью функции возведения в степень, при условии, что основание - число вещественное, а показатель - целое.


Function St(O:real;P:integer):real;
Begin
result:=1;
For P:= 1 to P do
    result:=result*P;
End;

Var
X:real;
n:integer;
Begin
Write('x = ');
ReadLn(x);
Write('n = ');
ReadLn(n);
WriteLn('S = ',x*x*x*(1+x*x)+St(x,n));
End.

(34.0k баллов)
0

в 6 строке выдаёт ошибку

0

Turbo? Free? ABC? Lazarus? Delphi? ABC.net?

0

ABC.net

0

Ну да, забыл знак умножения поставить - исправил

0

СПАСИБО!!!