Помогите пожалуйста решить задачу в Pascal ABC Написать программу, которая вычисляет...

0 голосов
72 просмотров

Помогите пожалуйста решить задачу в Pascal ABC Написать программу, которая вычисляет факториал числа, введенного с клавиатуры. (факториал числа n называется произведение целых чисел от 1 до n. Например, факториал числа 1 равен 1, а числа 8 – 40320.)
Вычисление факториала.
Введите число, факториал которого надо вычислить -> 7
Факториал 7 равен 5040.


Информатика (22 баллов) | 72 просмотров
0

ABC.net или просто ABC ?

0

abc.net

Дан 1 ответ
0 голосов
Правильный ответ

Var
N:integer;
F:BigInteger:=1;
Begin
Write('N = ');Read(N);
For N:= 1 to N do
    F:=F*N;
Write(N,'! = ',F)
End.

(34.0k баллов)
0

спасибо