1) Написать программу,которая формирует СЛУЧАЙНЫМ образом МАССИВ из N целых чисел,лежащих...

0 голосов
136 просмотров

1) Написать программу,которая формирует СЛУЧАЙНЫМ образом МАССИВ из N целых чисел,лежащих в диапазоне от 1 до 5,после чего на экран выводится САМ МАССИВ и НОМЕРА элементов совпадающих с ПЕРВЫМ элементом.
2)Написать программу,которая вводит МАССИВ и N ЦЕЛЫХ чисел и выводит на экран элементы,КРАТНЫЕ к числу К.
3)Написать программу,которая вводит МАССИВ из N ВЕЩЕСТВЕННЫХ чисел,а затем ЗАМЕНЯЕТ в нем все элементы,превышающие данное число Z,этим числом.Вывести на экран ПОЛУЧЕННЫЙ МАССИВ и КОЛИЧЕСТВО ЗАМЕН.


Информатика (61 баллов) | 136 просмотров
0

Паскаль? Бейсик? С++?

0

паскаль

Дан 1 ответ
0 голосов
Правильный ответ

Задание #1.

const
N = 10;

var
a : array[1..N] of integer;

begin

    randomize;
    for I : byte := 1 to N do
    begin 
       a[i] := random(1, 5);
       write(a[i],' ');
    end;

    for I : byte := 2 to N do
    if a[1] = a[i] then writeln(i);

end.

Задание #2.

const
K = 2;
N = 10;

var
a : array[1..N] of integer;

begin

    for I : byte := 1 to N do
    begin
       readln(a[i]);
       if a[i] mod k = 0 then write(a[i],' ');
    end;  

end.

Задание #3.

const
Z = 2;
N = 10;

var
a : array[1..N] of integer;
count : word;

begin

    count := 0; 

    for I : byte := 1 to N do
    begin
       readln(a[i]);
       if a[i] > Z then
       begin
          a[i] := Z; 
          Inc(count);
       end;
end;

      for I : byte := 1 to N do
      write(a[i],' '); 

      writeln;

      writeln(count);

 end.

Стоит на на всякий случай пояснить, что N, K, Z - константы, их можно легко поменять, так гораздо удобнее работать с программой, если нужно что-то поменять. Процедура Inc( ) - прибавляет единицу, это короче чем писать Count := Count + 1;  В первом задание в цикле, который ищет значение элементов массива, которые равны первому элементу массива, я начал со второго элемента. потому что очевидно, что первый элемент будет равен самому себе. Надеюсь, вам поможет, написанные мной программы, она не сложные, вам стоит внимательно их просмотреть и, вы сможете без труда их понять самостоятельно, если пожелаете, разумеется.

(52 баллов)