Помогите написать программу(см.картинку)

0 голосов
33 просмотров

Помогите написать программу(см.картинку)


image

Информатика (100 баллов) | 33 просмотров
0

№6?

0

Да

0

Ок

0

На чем писать?

Дан 1 ответ
0 голосов
Правильный ответ

//Алгоритм: Решето Эратосфена
const n=1000;
var
i, j, count: integer;
b: array[1..n] of boolean;
begin
count:=0;
for i:=1 to n do b[i]:=false;
  for i:=2 to n do
    if not b[i] then
    begin
     inc(count);
     //write (i, '; ');
     j:=1;
      while (i*j<=n) do<br>      begin
       b[i*j]:=true;
       inc(j);
      end;
    end;
write (count);
end.

(3.8k баллов)