По данному натуральному значению n вычислите 1+1/3+1/5+1/7+...+1/2n+1 ** вход программе...

0 голосов
64 просмотров

По данному натуральному значению n вычислите
1+1/3+1/5+1/7+...+1/2n+1
на вход программе подаётся натуральное число n<100000


Информатика | 64 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
  i,n:integer;
  s:real;
begin
  Write('n='); Read(n);
  s:=1;
  for i:=1 to n do s:=s+1/(2*i+1);
  Writeln('S=',s)
end.

Пример
n=10
S=2.1808745777786

(150k баллов)