По данному натуральному значению n вычислите 1+1/3+1/5+1/7+...+1/2n+1 ** вход программе...

0 голосов
61 просмотров

По данному натуральному значению n вычислите
1+1/3+1/5+1/7+...+1/2n+1
на вход программе подаётся натуральное число n<100000


Информатика | 61 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.2, сборка 1387 от 20.02.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln('S=',1+Range(1,ReadInteger('n=')).Select(i->1/(2*i+1)).Sum)
end.

Пример:
n= 10
S=2.1808745777786
(150k баллов)
0

Прошу прощения, я правильно понял, что первые 4 члена последовательности: 1+1/3+1/5+1/7 ?