!!! 50 БАЛЛОВ!!! НАПИШИТЕ ПРОГРАММУ. В первой строке вводится натуральное чило n Вывести...

0 голосов
54 просмотров

!!! 50 БАЛЛОВ!!! НАПИШИТЕ ПРОГРАММУ. В первой строке вводится натуральное чило n
Вывести на экран
- произведение нечетных цифр числа
(считается, что хотя бы одна нечетная цифра в числе имеется)
На C++ пж


Информатика (31 баллов) | 54 просмотров
Дан 1 ответ
0 голосов

#include
using namespace std;

int main() { 
   int n,k=1,m,p=0;
   cout<<"n = ";  cin>>n;
   while (n>0) {
     m=n%10;
     if (m%2==1) {k*=m; p=1; }
     n=n/10;
   }
   if (p>0) cout<<"result: "<<k;<br>   else cout<<"no odd digits";<br>   cout<<endl;<br>
   system("pause");
   return 0;
}




(9.7k баллов)