Напишите программу вывода нечетных чисел от 1 до n

0 голосов
68 просмотров

Напишите программу вывода нечетных чисел от 1 до n


Информатика (35 баллов) | 68 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
// PascalABC.NET 3.2, сборка 1385 от 14.02.2017

begin
  var n:=ReadInteger('n=');
  Range(1,n,2).Println
end.

Пример
n= 58
1 3 5 7 9 11 13 15 17 19 21 23 25 27 29 31 33 35 37 39 41 43 45 47 49 51 53 55 57

(150k баллов)
0 голосов

Program n1;
var n,i: integer;
begin
readln(n);
for i:=1 to n do if i mod 2<>0 then write(i,' ');
end.

(149k баллов)