Напишите программу ** C++, которая вычисляет значение выражения: y=1+2^2+3^3+...+n^n (n...

0 голосов
62 просмотров

Напишите программу на C++, которая вычисляет значение выражения:

y=1+2^2+3^3+...+n^n (n вводится пользователем)


Информатика (25 баллов) | 62 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//MV C++ 2010
#include
#include
using namespace std;

long double forpow(int n)
{
double i;
long double rez=0;
  for (i=1; i<=n; i++) rez+=pow(i, i);<br>return rez;
}

int main()
{
  int a;
  cin >>a;
  cout<<forpow(a);<br>return 0;
}

(3.8k баллов)
0

Ещё раз огромнейшее спасибо!