Пж помогите срочно !!!Напишите программу которая проверяет является ли введенное...

0 голосов
45 просмотров

Пж помогите срочно !!!Напишите программу которая проверяет является ли введенное натуральное число положительным кратным 7 ( на языке Паскаль ) даю 40 баллов


Информатика (64 баллов) | 45 просмотров
0

на положительность тоже проверять?

Дано ответов: 2
0 голосов
Правильный ответ

Program ch;
var a: integer;
begin
readln(a);
if(a mod 7=0) and (a>0) then writeln('yes');
else writeln('no');
end.

(150k баллов)
0 голосов

Var x:integer;
begin
read(x);
if(x<=0)then write('Не положительное') <br>   else  if(x mod 7 <>0)then write('Не кратно 7')  
      else write('Положительное и кратно 7');
end.

(2.1k баллов)