Написать программу которая определит сумму всех цифр пятизначного числа x(вводятся с...

0 голосов
37 просмотров

Написать программу которая определит сумму всех цифр пятизначного числа x(вводятся с клавиатуры) и вывести на экран сообщение.И определить заканчивается эта сумма на 3,является ли эта сумма четным


Информатика (66 баллов) | 37 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//PascalABC.Net 3.2
begin
var x:=readinteger ('Введите x: ');
var sum:=0;
repeat
sum+=x mod 10;
x:=x div 10;
until x=0;
writeln ('Сумма цифр: ', sum);
writeln ('Сумма заканчивается на 3: ', (sum mod 10)=3);
writeln ('Сумма четная - ', sum.Iseven);
end.

(3.8k баллов)