Написать программу Pascal ABC. Написать программу которая по определенным числам a и b и...

0 голосов
86 просмотров

Написать программу Pascal ABC. Написать программу которая по определенным числам a и b и введеному действию выполняет вычисление. Программу надо сделать с оператором Case m of. ПОМОГИТЕ ПОЖАЛУЙСТА.


Информатика (22 баллов) | 86 просмотров
Дан 1 ответ
0 голосов

Var a,b:integer; // числа

    sym:char; // действие/знак

begin

readln(a,b);

readln(sym);

case sym of 

'+': writeln(a+b);

'-': writeln(a-b);

'*': writeln(a*b);

'/': writeln(a/b);

end;

end.

(1.1k баллов)
0

Мы еще не прошли Sym

0

sym это название переменной

0

case *Переменная* of ... В данном случаи это переменная sym типа char определяющая действие при вводе

0

Ну у меня программаа не работает

0

На одной строке вводишь 2 числа, на следующей знак + - * /. У меня все работает

0

readln(a,b); вот здесь не оошибку выдаёт

0

Можешь заново переписать её пожалуйста

0

я написал в личные сообщения