Помогите пожалуйста решить три задачки по информатике за 9й класс. 1) Напишите программу...

0 голосов
50 просмотров

Помогите пожалуйста решить три задачки по информатике за 9й класс.

1) Напишите программу нахождения суммы денег вырученных от продажи газет B, если он зарабатывает А рублей на продажей каждой газеты. Кол-во газет и цена штуки вводятся вручную с клавиатуры.

2) Напишите программу вычисления сторон треугольника a, b, c, если треугольник задан координатами вершин (х1:y1), (x2:y2), (x3:y3) длинна стороны вычисляется по формуле a = √(х2-х1)^2 +√(y2-y1)^2

3) Третья задачка будет фотографией, если тут можно прикреплять файл вообще ))


Заранее огромное спасибо и + вам в карму )


image

Информатика (288 баллов) | 50 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

1)program сумма;
var
a, b, c: integer;
begin
writeln('Введите кол-во проданных газет.');readln(a);writeln('Введите цену одной газеты.');readln(b);writeln('Cумма денег, вырученных от продажи газет, равна ', a*b);
end.----------------------------------------------------------------------------------------------------
2)program нахождениесторонтреугольника;var x1,x2,x3,y1,y2,y3,a,b,c : real; begin write('x1='); readln(x1); write('y1='); readln(y1);
 write('x2='); readln(x2); write('y2='); readln(y2); write('x3='); readln(x3); write('y3='); readln(y3); a:=sqrt(sqr(x1-x2)+sqr(y1-y2)); b:=sqrt(sqr(x2-x3)+sqr(y2-y3)); c:=sqrt(sqr(x3-x1)+sqr(y1-y3));writeln('стороны треугольника равны ',a,', ',b,', ',c); end.
-----------------------------------------------------------------------------
3)program нахождениеY;
var
a, b, c, s, k, y: real;
begin
writeln('Введите a.');readln(a);writeln('Введите b.');readln(b);writeln('Введите с.');readln(c);s := (sqrt(a+b*b*b*b*b)/3*c);k := s - sqrt(abs(a*b*c));y := s + k - (s/b*c);writeln(y);
end.

(326 баллов)
0

Боже храни не гумунитариев :D Добра тебе и всего, чего там обычно надо))) Если нужна будет помощь по правовым дисциплинам и литератури - милости прошу )

0

Рада помочь)Только после "var", ";" с новой строки начинай.

0

Да про "var" помню )) вот так изучаешь год паскаль в колледже, с красным дипломом его кончаешь, а потом просишь помощи решить школьные задачки на сайтах :D Даж как-то грустновато((

0

Да, без постоянной практики забывается, я бы сама бы плохо знала, если бы не планировала связывать жизнь с программированием

0

У меня лучший друг отучился на сисадмина ( там сетевая безопасность у него и сети ) а как универ закончил с осени работает кодером, лепит сайты...он сказал, что конечно это легко, но это не то на что он расчитывал поступая в универ :D

0

Ахах, тоже немало слышала о таком

0

Мне хорошо, с моей кафедры конституционного права хоть на рынок торговать, в пятёрочку охранником, в армию уборщиком, в цирк зазывалой :D Вот она ориентированность проф.образования во всей красе