Напишите программу,выводящую ** экран все отрицательные числа из диапазона (m;n)

0 голосов
81 просмотров

Напишите программу,выводящую на экран все отрицательные числа из диапазона (m;n)


Информатика (15 баллов) | 81 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var m,n,k,i:integer;
begin
write('m, n: ');
readln(m,n);
if nif m>=0
 then writeln('В диапазоне [',m,',',n,'] нет отрицательных чисел')
 else if n>0 then for i:=m to -1 do write(i,' ')
             else for i:=m to n do write(i,' ');
end.

Пример:
m, n: -5 2
-5 -4 -3 -2 -1 

(194k баллов)