Используя, оператор цикла Repeat . . . until написать программу

0 голосов
103 просмотров

Используя, оператор цикла Repeat . . . until написать программу


image

Информатика (53 баллов) | 103 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Const e=0.001;
var x,a,s:real; n,st,f:integer;
begin
write('x = ');
readln(x);
st:=1; f:=1; a:=x; s:=x; n:=0;
while abs(a)>e do
 begin
 n:=n+1;
 st:=st*2;
 f:=f*n;
 a:=x*st/f;
 s:=s+a;
 end;
writeln('s = ',s:5:3);
end.

Пример:
x = 1.5
s = 11.083

(194k баллов)