ПОМОГИТЕ ПОЖАЛУЙСТА! ПАСКАЛЬ! ---------------------------------- Напишите программу,...

0 голосов
55 просмотров

ПОМОГИТЕ ПОЖАЛУЙСТА! ПАСКАЛЬ!
----------------------------------
Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, последняя цифра которых равна А и все число делится на В. Последовательность чисел заканчивается числом 0. Числа А и В вводятся до цикла.
(должен быть цикл while)


Информатика (47 баллов) | 55 просмотров
Дан 1 ответ
0 голосов

Var
  a, b, num, sum: integer;

begin
  readln(a, b);
  readln(num);
  while num <> 0 do
  begin
    if (num mod 10 = a) or (num mod b = 0) then
      sum := sum + num;
    readln(num);
  end;
  writeln(sum)
end.

(4.7k баллов)
0

num - это последовательность чисел?

0

вводимые числа последовательности

0

ок