Написать программу решения уравнения Ax(в 3 степени ) + Bx=0 для произвольных А, В,...

0 голосов
128 просмотров

Написать программу решения уравнения Ax(в 3 степени ) + Bx=0 для произвольных А, В, значения которых вводятся с клавиатуры


Информатика (16 баллов) | 128 просмотров
Дан 1 ответ
0 голосов
ax^3+bx=0
x(ax^2+b)=0
Получим несколько решений:
1.)x=0
2.)ax^2+b=0
ax^2=-b
x^2=- \frac{b}{a}
x_{1} = \sqrt{- \frac{b}{a}}
x_{2} = -\sqrt{- \frac{b}{a}}

var
  a, b: real;

begin
  readln(a, b);
  writeln('x = 0');
  if (-b/a) >= 0 then
  begin
    writeln('x = ', sqrt(-b/a));
    writeln('x = ', -sqrt(-b/a));
  end;
end.
(4.7k баллов)