Напишите программу(паскаль) нахождения суммы элементов массива А[1..15], кратных 5 и...

0 голосов
45 просмотров

Напишите программу(паскаль) нахождения суммы элементов массива А[1..15], кратных 5 и меньших 50. Массив заполняется произвольными числами в диапазоне да 100


Информатика (94 баллов) | 45 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Const N = 15;
Var
   A:array[1..N] of integer;
   i:integer;
   S:real;
Begin
S:=0;
Write('Исходный массив: ');
For i:= 1 to N do
    Begin
    A[i]:=random(100);
    Write(A[i],' ');
    if (A[i]<50)and(A[i] mod 5 = 0) then S:=S+A[i];<br>    End;
WriteLn;
WriteLn('S = ',S);
End.

(34.0k баллов)