Нужно написать программу срочно!!!!!
На чем: C++, Python, Pascal`и?
Pascal
Ок
//PascalABC.Net 3.2 function f(x: real):real; begin if x=trunc(x) then if trunc(x).iseven then result:=x*x*x*x*x else result:=1/(x*x-10) else result:=x; end; begin write ('y = ', f(readreal('x ='))); end.
Можно написать "проще"
Только незачем!