Напишите программу, которая определяет, верно ли, что введённое число содержит две...

0 голосов
63 просмотров

Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковые цифры, стоящие рядом (как, например, 221)
Желательно программу на Паскале


Информатика (19 баллов) | 63 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program n1;
var a,temp: integer;
b: boolean;
begin
readln(a);
temp:=-a;
b:=false;
while a<>0 do
begin
if temp=(a mod 10) then begin
b:=true;
break;
end;
temp:= a mod 10;
a:=a div 10;
end;
if b then write('верно') else write('неверно');
end.

(149k баллов)