Написать программу в Паскале Ввести натуральное число N и вычислить сумму всех чисел...

0 голосов
333 просмотров

Написать программу в Паскале




Ввести натуральное число N и вычислить сумму всех чисел Фибоначчи, меньших N. Предусмотрите защиту от ввода отрицательного числа N. Пример: Введите число N: 10000 Сумма 17709


Информатика (1.0k баллов) | 333 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var n,f1,f2,fn,sum:integer;
begin
write('n = ');
readln(n);
while n<=0 do<br> begin
 writeln('Введите n>0. n = ');
 readln(n);
 end;
f1:=1; f2:=1;
fn:=f1+f2;
while fn begin
 sum:=sum+fn;
 fn:=f1+f2;
 f1:=f2;
 f2:=fn;
 end;
writeln('sum=',sum);
end.

Пример:
n = -10
Введите n>0. n = 10000
sum=17710

(194k баллов)
0 голосов

Var A,B,N:integer;
S:real;
Begin
A:=0;
B:=1;
Write('N = ');
ReadLn(N);
if N<0 then Write('Введите положительное число')<br>else
   Begin
   While A      Begin
      S:=S+A;
      A:=A+B;
      Swap(A,B);
      Write(A,' ');
      End;
   WriteLn;
   WriteLn('S = ',S)
   End;
End.

Пример:
N = 10000
1 1 2 3 5 8 13 21 34 55 89 144 233 377 610 987 1597 2584 4181 6765 10946
S = 17710

Примечание:
Условие немного некорректно, т.к.
1+1+2+3+5+8+13+21+34+55+89+144+233+377+610+987+1597+2584+4181+6765 = 17710.


(34.0k баллов)