Написать программу в паскаль по алгоритму. Фото внутри

0 голосов
45 просмотров

Написать программу в паскаль по алгоритму. Фото внутри


image
image

Информатика | 45 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var a,b,c,max:real;
Begin
Write('a = ');ReadLn(a);
Write('b = ');ReadLn(b);
Write('c = ');ReadLn(c);
if a>b then
   if a>c then max:=a
   else max:=c
else
   if b>c then max:=b
   else max:=c;
WriteLn(max)
End.



Var a,b,c,D:real;
Begin
Write('a = ');ReadLn(a);
Write('b = ');ReadLn(b);
Write('c = ');ReadLn(c);
D:=b*b-4*a*c;
if D>=0 then
   Begin
   WriteLn('x1 = ',(-b-sqrt(D))/(2*a));
   WriteLn('x2 = ',(-b+sqrt(D))/(2*a));
   End
else
   if c<>0 then WriteLn('Корней нет')
   else Write('Любое число')
End.

(34.0k баллов)