Напишите программу в pascal abc Для первых n натуральных чисел вычислить сумму чисел,...

0 голосов
28 просмотров

Напишите программу в pascal abc
Для первых n натуральных чисел вычислить сумму чисел, кратных 3 и сумму всех чисел.


Информатика (207 баллов) | 28 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
   n,S,S3:integer;
Begin
Write('n = ');
ReadLn(n);
For n:= 1 to n do
    Begin
    S:=S+n;
    if n mod 3 = 0 then S3:=S3+n;
    End;
WriteLn('Сумма чисел [1..',n,'], кратных трём: ',S3);
WriteLn('Сумма всех чисел [1..',n,']: ',S);
End.

(34.0k баллов)