Составить программу в Паскале: Если товар сначала подорожал ** 10%, а затем подешевел **...

0 голосов
34 просмотров

Составить программу в Паскале: Если товар сначала подорожал на 10%, а затем подешевел на 10%, то на сколько процентов изменилась цена товара?


Информатика (145 баллов) | 34 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Const p1=10; p2=10;
var p:real;
begin
p:=100-(100+p1)*(100-p2)/100;
if p>0
 then writeln('Товар подешевел на ',p:3:1,'%')
 else writeln('Товар подорожал на ',-p:3:1,'%');
end.

Результат:
Товар подешевел на 1.0%

(194k баллов)
0 голосов

Надеюсь помог..............

(28 баллов)
0

Огромное спасибо!!!