Написать программу, которая печатает введенное слово, начиная с последней буквы C++

0 голосов
94 просмотров

Написать программу, которая печатает введенное слово, начиная с последней буквы C++


Информатика | 94 просмотров
0

То есть, перевёрнутое слово?

Дано ответов: 2
0 голосов
Правильный ответ
#include  

void RevStr(char* S,int l)
{  
   char c;  
   if (l > 1)  
   {      
      c=S[0];      
      S[0]=S[l-1];      
      S[l-1]=c;      
      RevStr(S+1,l-2);    
   }
}  

int main(int argc, char* argv[])
{    
   char S[12]="
Test of pen";       
   RevStr(S,11);    
   std::cout << S << std::endl;    <br>   return 0;
}
(314k баллов)
0

вывод gnirts tset

0 голосов

#include
#include
using namespace std;
string s;
int main ()
{
cin >> s;
reverse (s.begin(), s.end());
cout << s;<br> return 0;
}

(33 баллов)
0

#include
#include

0

iostream
algorithm