Напишите программу в паскале ABC, и нарисуйте к ней блок-схему. Вводится массив из 15...

0 голосов
43 просмотров

Напишите программу в паскале ABC, и нарисуйте к ней блок-схему.
Вводится массив из 15 элементов,нужно определить сколько эл. массива будут между его макс и миним. элементом.


Информатика (226 баллов) | 43 просмотров
Дан 1 ответ
0 голосов

Var
i,max,min,res,maxi,mini:integer;
a: array [1..15] of integer;
begin
writeln('Введите числа');
for i:=1 to 15 do
read(a[i]);
max:=a[1];
min:=a[1];
for i:=1 to 15 do
begin
if maxmax:=a[i];
maxi:=i;
end;
if min>a[i] then begin
min:=a[i];
mini:=i;
end;
end;
if maxi>mini then
res:=maxi-mini
else
res:=mini-maxi;
res:=res-2;
writeln('между максимум и минимум = ', res, ' элементов');
end.


image

(1.8k баллов)