Напишите программу по блок-схеме.

0 голосов
33 просмотров

Напишите программу по блок-схеме.


image

Информатика (106 баллов) | 33 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var x,p,s:real; n,i:integer;
begin
write('x = ');
readln(x);
write('n = ');
readln(n);
s:=1; p:=1;
for i:=1 to n do
 begin
 p:=-p*x/i;
 s:=s+p;
 end;
writeln('s = ',s);
end.

Пример:
x = 0.5
n = 5
s = 0.606510416666667

(194k баллов)