Помогите написать программу в Pascal!

0 голосов
27 просмотров

Помогите написать программу в Pascal!


image

Информатика (1.2k баллов) | 27 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
1. Современное решение

// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadArrReal('Вводите:',ReadInteger('Кол-во чисел?'));
  Writeln('Ср.арифметическое равно ',a.Average)
end.

Пример
Кол-во чисел? 5
Вводите: 3.18 4.7 2.94 4 6.2
Ср.арифметическое равно 4.204

2. Школьный вариант в стиле ТурбоПаскаль 1983г.

const
  nn=100;
var
  n,i:integer;
  a:array[1..nn] of real;
  s:real;
begin
  Write('Кол-во чисел? ');
  Read(n);
  Write('Вводите: ');
  for i:=1 to n do begin
    Read(a[i]);
    s:=s+a[i]
    end;
  Writeln('Ср.арифметическое равно ',s/n)
end.
(150k баллов)