PascalABC Нужно написать программу с "IF" Вот сама задача: Даны два угла теугольника (в...

0 голосов
77 просмотров

PascalABC
Нужно написать программу с "IF"
Вот сама задача: Даны два угла теугольника (в градусах) (которые вводит пользователь). Определить, существует ли такой треугольник. Если да, то будет ли он прямоугольным?


Информатика (496 баллов) | 77 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
    a, b: integer;

begin
    readln(a, b);
    if a + b >= 180 then
        writeln('Такой треугольник не может существовать')
    else if (a = 90) or (b = 90) or (a + b = 90) then
        writeln('Это прямоугольный треугольник')
    else
        writeln('Это треугольник')
end.

если надо записать в стиле PascalABC.Net, скажи допишу

(55.0k баллов)