Напишите программу, которая вычисляет сумму: а) первых n натуральных чисел; б) квадратов первых n натуральных чисел;
Var n:integer; S:real; Begin Write('n = ');ReadLn(n); S:=0; For n:= 1 to n do S:=S+n; WriteLn('а) S = ',S); S:=0; For n:= 1 to n do S:=S+n*n; WriteLn('б) S = ',S); End.
A) begin write(seqgen(readinteger(), x -> x + 1, 0).Sum); end. б) begin write(seqgen(readinteger(), x -> x * x, 1).Sum); end.