Нужно написать программу ** паскале обязательно используя цикл For. Программа вычисляет...

0 голосов
37 просмотров

Нужно написать программу на паскале обязательно используя цикл For.

Программа вычисляет среднее арифметическое положительных элементов ряда чисел. Каждый элемент ряда вычисляется по формуле: (12*K-21)/3, где K--номер элемента в ряду. Всего элементов--необходимо спросить.


Информатика (17 баллов) | 37 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var K,n:integer;
S:real;
Begin
n:=0;
Write('K = ');ReadLn(K);
For K:= 1 to K do
    Begin
    Write((12*K-21)/3,' ');
    if (12*K-21)/3 > 0 then
       Begin
       S:=S+(12*K-21)/3;
       n:=n+1
       End;
    End;
WriteLn;
Write('Sr = ',S/n)
End.

(34.0k баллов)