Pascal ABC. Написать программу которая определяет знак зодиака при вводе даты рождения (с...

0 голосов
69 просмотров

Pascal ABC. Написать программу которая определяет знак зодиака при вводе даты рождения (с использованием case).


Информатика (5.7k баллов) | 69 просмотров
Дан 1 ответ
0 голосов

Var n,d:integer;
begin
write('Введите месяц :');
readln(n);
write('Введите день :');
readln(d);
n:=n mod 12;

 case n mod 12 of
 1: if d<=20 then writeln('Козерок') else writeln('Водолей');<br> 2: if d<=21 then writeln('Водолей') else writeln('рыба');<br> 3: if d<=21 then writeln('рыба')   else writeln('овен');<br> 4: if d<=21 then writeln('овен')   else writeln('телец');<br> 5: if d<=21 then writeln('телец')   else writeln('близницы');<br> 6: if d<=22 then writeln('близницы')   else writeln('рак');<br> 7: if d<=23 then writeln('рак')   else writeln('лев');<br> 8: if d<=24 then writeln('лев')   else writeln('дева');<br> 9: if d<=24 then writeln('дева')   else writeln('весы');<br> 10: if d<=24 then writeln('весы')   else writeln('скорпион');<br> 11: if d<=23 then writeln('скорпион')   else writeln('стрелец');<br> 12: if d<=22 then writeln('стрелец')   else writeln('козерок');<br>end;
end.

//без if вряд ли удаться обойтись(+ я не учитывал високосный год и кратный 100 и 400)

(577 баллов)
0

Не, не так. Нужно знак зодиака, например, водолей, козерог

0

а как добавить "этой даты не существует" при вводе 30 феврпля?