Написать программу для задачи ** турбо паскале Заданы координаты трёх точек ** плоскости...

0 голосов
56 просмотров

Написать программу для задачи на турбо паскале Заданы координаты трёх точек на плоскости а(x1,y1) b(x2,y2) c(x3,y3) Найдите расстояние между точками ab и ac по форумуле d=корень из(x2-x1)^2+(y2-y1)^2 x1=8 y1=12 x2=12.5 y2=14 x3=-3.5 y3=-5.2


Информатика (22 баллов) | 56 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var x1,x2,x3,y1,y2,y3:integer;
begin
read(x1,y1);
read(x2,y2);
read(x3,y3);
writeln('ab',sqrt(sqr(x2-x1))+sqr((y2-y1))));
writeln('ac',
sqrt(sqr(x3-x1))+sqr((y3-y1))));
end.

(14.6k баллов)