СРОЧНО!! ПАСКАЛЬ!! Вводится какое-то кол-во секунд, из этих секунд программа должна...

0 голосов
72 просмотров

СРОЧНО!! ПАСКАЛЬ!! Вводится какое-то кол-во секунд, из этих секунд программа должна вывести дни(сутки), часы, минуты, секунды... Прошу помочь


Информатика (53 баллов) | 72 просмотров
0

Нужно написать программу

Дано ответов: 2
0 голосов
Правильный ответ

Var sec:longint; d,h,m,s:integer;
begin
writeln('sec = ');
readln(sec);
d:=sec div (60*60*24);
h:=sec mod (60*60*24) div (60*60);
m:=sec mod (60*60) div 60;
s:=sec mod 60;
writeln('d = ',d,' h = ',h,' m = ',m,' s = ',s);
end.

Пример:
sec = 183925
d = 2 h = 3 m = 5 s = 25

(194k баллов)
0 голосов

Ответ в файле
...............


Скачать вложение Текст (TXT)
(14.3k баллов)
0

Нужно, чтобы выводил целые числа

0

исправил

0

Смотрите, допустим у меня есть число 85600(так к примеру) мне нужно найти сколько в этом числе дней, а из остатка найти сколько осталось часов в остатке, секунд и минут

0

Как успехи, поможете?