Напишите программу , которая сортирует массив, а затем находит максимальное из чисел ,...

0 голосов
238 просмотров

Напишите программу , которая сортирует массив, а затем находит максимальное из чисел , встречающихся в массиве несколько раз. Паскаль


Информатика (71 баллов) | 238 просмотров
0

Метод сортировки важен?

Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.2, сборка 1399 от 08.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-20,20); a.Println;
  Sort(a);
  var v:=a.Last;
  var found:=False;
  for var i:=a.High-1 downto 0 do
    if a[i]=v then begin Writeln(v); found:=True; break end
    else v:=a[i];
  if not found then Writeln('В массиве нет дубликатов')
end.

Пример
n= 15
-13 11 1 -19 14 2 20 -15 14 -10 -15 8 4 -2 -13
14
(150k баллов)