Помогите написать программу в паскале с помощью вложенных циклов

0 голосов
71 просмотров

Помогите написать программу в паскале с помощью вложенных циклов


image

Информатика (33 баллов) | 71 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET

var
  a,x,px,y:real;
  n:integer;
begin
  x:=0.1;
  while x<=0.9 do begin<br>    y:=0;
    px:=1;
    for n:=0 to 20 do begin
      if x<=0.5 then a:=2*n<br>      else a:=n/2;
      y:=y+a*px;
      px:=px*x
      end;
    y:=y*(sin(x)+2)/(3+cos(x));
    Writeln(x:3:1,y:16:9);
    x:=x+0.1
    end
end.

Результат
0.1     0.129781438
0.2     0.345262649
0.3     0.710645245
0.4     1.354178828
0.5     2.557675550
0.6     1.256653741
0.7     2.716085461
0.8     6.927006600
0.9    21.970170476
(150k баллов)
0

а как выполняются вот эти строчки? при поиске y мы умножаем опять же y

0

y:=y+a*px; y:=y*(sin(x)+2)/(3+cos(x));

0

И почему изначально берем y=0 не могли бы объяснить